さて、今回はPHPのお話です。

11月25日にPHP8.1.0正式版がリリースされました。

パフォーマンスもPHP8.0から向上するようです。

以下、PHPの公式サイトに記載がありました。



というわけで、今回は最新のPHP8.1.0でWordpressを動作させられるかの検証したいと思います。
筆者宅には今はWEBサーバ環境が二台体制あるので、まずは予備機側で試すことにします。

BuildConfig.phpを修正する

OpenLiteSpeedのBuild_phpconfigを以下のように修正し、読み込めるようにします。


$sudo vi /usr/local/lsws/admin/html/lib/util/build_php/BuildConfig.php

以下のように配列の一番上の行に「’8.1.0′,」を追加します。

            case self::PHP_VERSION: return
						['8.1.0',
						'8.0.13',
						'8.0.12',
						'8.0.11',
						'8.0.7',
							'7.4.20',
							'7.3.28',
							'7.2.34',
							'7.1.33',
							'7.0.33',
							'5.6.40',
							'5.5.38',
							'5.4.45',
							'5.3.29'];

すると以下のようにOpenLiteSpeed側ではPHP8.1.0が表示されます。
次へで進めていきます。



そしてコンフィグは問題なく完了し、
コンパイルしたところ、30分ほど経過して以下の警告が出て終了しました。。。。


トップレベル:
/usr/local/lsws/phpbuild/php-8.1.0/sapi/litespeed/lsapi_main.c:860:12: 警告: ‘lsapi_fopen_primary_script’ defined but not used [-Wunused-function]
  860 | static int lsapi_fopen_primary_script( zend_file_handle * file_handle )
      |            ^~~~~~~~~~~~~~~~~~~~~~~~~~
次のファイルから読み込み:  /usr/local/lsws/phpbuild/php-8.1.0/sapi/litespeed/lsapi_main.c:67:
/usr/local/lsws/phpbuild/php-8.1.0/sapi/litespeed/lscriu.c:305:14: 警告: ‘LSCRIU_Error_File_Name’ defined but not used [-Wunused-function]
  305 | static char *LSCRIU_Error_File_Name(char *pchFile, int max_len)
      |              ^~~~~~~~~~~~~~~~~~~~~~
/usr/local/lsws/phpbuild/php-8.1.0/sapi/litespeed/lscriu.c:88:12: 警告: ‘s_criu_debug’ defined but not used [-Wunused-variable]
   88 | static int s_criu_debug = 0;
      |            ^~~~~~~~~~~~
make: *** [Makefile:600: sapi/litespeed/lsapi_main.lo] エラー 1
**ERROR** Could not compile PHP

lscriu.c:305、lscriu.c:88:12とあるので、OpenLiteSpeed側のバグなのかな?
と思います。一旦はOpenLiteSpeedとPHPの両方の路線で情報を待ちますかね。

筆者はOpenLiteSpeedは9月リリースのバージョン1.7.14を使用しています。

また進展あれば本ブログで報告致します。